Menu items not displayed

Topics: Developer Forum
Mar 21, 2007 at 9:42 AM
I've just installed version 1.0 of the add-in, but the "Extract to Resource" item doesn't appear on the Refactor menu. I haven't used any previous versions on the add-in, and have tried uninstalling and re-installing.

Any ideas on how to fix it?
Coordinator
Mar 21, 2007 at 1:28 PM
Which version of Visual Studio are you using? Also which type of project/solution you are working on while trying to use Resource Refactoring tool.

Thanks,
Bertan
Mar 21, 2007 at 8:43 PM
Edited Mar 23, 2007 at 10:42 AM
I'm using Visual Studio 2005 with a solution that has number of C# projects (windows forms apps and class libraries).

Thanks,
Stuart
Mar 23, 2007 at 10:49 AM
I've also tried it with a solution containing a single class library project.

Stuart
Apr 19, 2007 at 9:14 PM
i also have this problem...
and i i check some other power toys alos have this problem, like the VS Command Shell...
my env is :
VS2005 TS chinese edition

by the way, this is anthor fooly question , how can i debug a addin project
Apr 26, 2007 at 8:13 PM
Edited Apr 26, 2007 at 8:13 PM
I have the same problem too.

Can this work alongside Resharper? The thing is Resharper adds a menu group Refactor... Therefore, when I right-click I have two menu Refactor, can this cause the problem that the "Extract to Resource" does not appear anywhere?

I would love to use this tool!
Thanks.
Joe
Oct 16, 2007 at 2:48 PM
Copy ResourceRefactor.AddIn from C:\Documents and Settings\Administrator\Application Data\Microsoft\MSEnvShared\Addins to C:\Documents and Settings\All Users\Application Data\Microsoft\MSEnvShared\Addins and grant read access for everyone. Now it works fine.
Apr 4, 2011 at 8:23 PM

I tried this method with Windows XP and VS 2010 and it does not solve my issue.  Any other ideas?  I am using a C# project.

Apr 4, 2011 at 8:59 PM

 

My solution was to uninstall the addin, clean the registry, restart and then reinstall.  Everything is working as expected now.