Support in Vs2008 ?

Nov 28, 2007 at 5:57 AM
This is a very useful tools .Thanks for the guys woking on it .
And does it support in vs2008 ?
Or we can compile the source code and make the msi myself to use it in vs2008 ?
Any advice ?

Thanks.
Coordinator
Nov 28, 2007 at 1:02 PM
Tool supports VS 2008 but the installer doesn't, so the installer has to be modified. We were planning to check in changes very soon, but you can modify the msi for now as well.

Thanks,
Bertan
Coordinator
Nov 29, 2007 at 12:56 AM
I updated the installer today so if you download the new release, it should install for VS2008 as well.
Dec 6, 2007 at 9:17 AM
It seems that when both VS2005 and VS2008 are installed, Resource Refactoring Tool is not installed on VS2008. At least, I cannot find the menu item anywhere, even when editing source code.
Feb 21, 2008 at 7:40 PM
Please wake up guys.
It still DOES NOT INSTALL for VS2008!!!
Feb 27, 2008 at 5:41 PM
I tried pulling down the latest bits and building myself... but that doesn't work as I don't have Wix installed. Can someone please publish a release that has support for VS 2008 baked in?

Thanks.
Coordinator
Feb 27, 2008 at 6:53 PM
If you have VS 2008, could you check from Tools -> Add-in Manager to see if Resource Refactoring is visible there, also the addin description is installed to local profile\Microsoft\MSEnvShared\Addins folder. You can check to see if that directory is included in add-in search list from Tools->Options=>Add-in/Macros Security in visual studio.

Thanks,
Bertan

Mar 12, 2008 at 11:34 AM
i have seen that in
%Application Data%\Microsoft\MSEnvShared\Addins\ResourceRefactor.AddIn

the <HostApplication>
Microsoft Visual Studio 10.0 is MISSING

have added it but in vs2008 it doesnt still work.

i have vs2005 installed too on my machine.
Mar 20, 2008 at 11:00 AM
FWIW this works fine for me. I have VS2005 and VS2008 installed and the Resource Refactoring Tool installs and runs fine in both VS2005 and VS2008. I didn't have to take any additional steps to get it to work.

Guy
Apr 2, 2008 at 8:08 AM
I cannot get this to work in vs2008. It does not appear in the Add-in Manager. The addin description is installed in local profile, and that directory is included in the add-in search list.

I have had vs 2005 installed, but have removed it, but this did not solve the problem.
May 6, 2008 at 1:32 PM
I've installed the last version of the add-in to work with it in VS 2008 v9.0.21022.8 RTM and it doesn't work in the sense that the menu item is not displayed in the pop-up menu.
I've looked into the ResourceRefactor.Addin and I've found the following:

<Assembly>C:\Program Files\Power Toys for Visual Studio\Resource Refactoring Tool\\Microsoft.VSPowerToys.ResourceRefactor.dll</Assembly>

It looks like a typing error to me, with no complaints raised about it by the host!.

Furthermore, I've checked the documentation for VS 2008 about the .Addin file, and I got to this:

*Following is an example of a local path location. In this case, the src parameter is set to file to indicate the local location of the add-in's DLL:
<Assembly src="file">C:\Documents and Settings\jdoe\Application Data\Microsoft\Visual Studio\8.0\AddIns\MyAddin4.dll</Assembly>

It looks like the src parameter specification is missing as well. After having fixed that in my .Addin file

<Assembly src="file">C:\Program Files\Power Toys for Visual Studio\Resource Refactoring Tool\Microsoft.VSPowerToys.ResourceRefactor.dll</Assembly>

I've run VS 2008 but still I cannot manage to get the menu item showing up in the pop-up menu. I'm sure the file is read by the host because I've also edited the <Description> tag's value and it's correctly reproduced in the Add-in Manager description.

I have no time to dig deep into the problem to investigate further at the moment, but I hope someone else find this info somewhat useful.
Jun 5, 2008 at 9:40 AM
I installed it and didn't see it in either vs2005 or vs2008.
So first I have removed bug with double backslash tnx Darkbreet.
Then I added path %Application Data%\Microsoft\MSEnvShared\Addins
In Tools->Options=>Add-in/Macros Security in visual studio.

P.S. I added full path instead of %Application Data% so if the above doesn't work try full path.

Hope it helps
Dec 9, 2008 at 2:57 PM
I have same problem.

Visual Studio 2005 + 2008 installed. I'm pretty sure it worked once (when I installed) but it won't show up in context menu anymore. I tried to fix '\\' issue, 'src="file"' and added path as raubam suggested (full path). But it didn't help. Any ideas what to do next ?

I also have GhostDoc and TestDriven.Net (disabled) installed. My profile path is c:\winnt\profiles\my_user_name\ if that matters ...
May 25, 2009 at 7:28 AM

That may make no sense at all, but I downloaded source code, compiled and ran it. For the the debug session (via F5), I launched a second Visual Studio who had the menu. Since then the menu always appears in Visual Studio 2008. Don't ask me why, but probably worth a shot.

Jan 24, 2010 at 4:21 AM

To get it work for me this is what I did:

1. Uninstall Resource Refactoring Tool.

2. Run CCleaner to clean up the registry.

3. Reboot the computer.

4. Launch VS 2008 to make sure the Tool was not longer in the Add in manager.

5. Re-install Resource Refactoring Tool.

Apr 5, 2010 at 8:26 AM

I think that i found the solution...
In my case i have installed the addin and all seems to be ok in tools->Addin menu..but i can't see the extract
to resource menu item.

I found that the item was added in the context menu using the text of the parent item ("Refactor" for english).
If you don't find the extract to resource item in the Refactor menu you can try as follow:
find in the CommandBar.resx the key xxRefactor where xx are the cultureInfo.TwoLetterISOLanguageName of your country
and modify the value of this key with exactly the string you have as parent in the Refactor menu.

suppose that you have a context menu  like this
sample 1:
   Refactoring
               ->Rename
        ->..
        ->Extract to interface
        ->...    
   ...
   Go to Definition
         ->...
  ..... 

  You have to modify the xxRefactor key with the string "Refactoring"

sample 2:
  Refactor
               ->Rename
        ->..
        ->Extract to interface
        ->...    
   ...
   Go to Definition
         ->...
  ..... 
You have to modify the xxRefactor key with the string "Refactor" (this is the normally value).

After that you have to rebuild and reistall and now all is ok..

Please let me know if this work or no